#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)\w*_\d{1}\.\d{1}\.zip"
Local $sString = "IDG_COM_UR_PREV_CLT_0.1.zip" & @CRLF & _
"IDG_COM_UR_PREV_CLT_0.2.zip" & @CRLF & _
"IDG_COM_UR_TEST_0.1.zip" & @CRLF & _
"IDG_COM_UR_TEST_0.2.zip" & @CRLF & _
"IDG_COM_UR_TEST_TEST_TEST_TEST_TEST_0.1.zip" & @CRLF & _
"IDG_COM_UR_TEST_TEST_TEST_TEST_0.2.zip"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")