re = /^\s*(?:
(?<protocol>https?)
\:[\/\\]{2}
(?<app>[\w\-]+)
\.
(?<client>[\w]+)
\-?
(?<environment>[\w]*)
\.
(?<audience>[\w\.]+)
\:?
(?<port>\d*)
[\\\/]
(?<instance>.*?)
)\s*$
/mxi
str = 'https://pii.ngkf-qa.commloanservices.com/qa2
https://pii.ngkf-qa.pncint.net/qa1
https://wlm-app.midlandls-qa.pncint.net/qa1-fdic
https://wlm-app.midlandls-qa.pncint.net/qa2fdic '
# Print the match result
str.scan(re) do |match|
puts match.to_s
end