#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?mxi)^\s*(?:" & @CRLF & _
" (?<protocol>https?)" & @CRLF & _
" \:[\/\\]{2}" & @CRLF & _
" (?<app>[\w\-]+)" & @CRLF & _
" \." & @CRLF & _
" (?<client>[\w]+)" & @CRLF & _
" \-?" & @CRLF & _
" (?<environment>[\w]*)" & @CRLF & _
" \." & @CRLF & _
" (?<audience>[\w\.]+)" & @CRLF & _
" \:?" & @CRLF & _
" (?<port>\d*)" & @CRLF & _
" [\\\/]" & @CRLF & _
" (?<instance>.*?)" & @CRLF & _
")\s*$" & @CRLF & _
"" & @CRLF & _
""
Local $sString = "https://pii.ngkf-qa.commloanservices.com/qa2 " & @CRLF & _
"https://pii.ngkf-qa.pncint.net/qa1 " & @CRLF & _
"https://wlm-app.midlandls-qa.pncint.net/qa1-fdic " & @CRLF & _
"https://wlm-app.midlandls-qa.pncint.net/qa2fdic "
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")