package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^\s*(?:
(?<protocol>https?)
\:[\/\\]{2}
(?<app>[\w\-]+)
\.
(?<client>[\w]+)
\-?
(?<environment>[\w]*)
\.
(?<audience>[\w\.]+)
\:?
(?<port>\d*)
[\\\/]
(?<instance>.*?)
)\s*$
`)
var str = `https://pii.ngkf-qa.commloanservices.com/qa2
https://pii.ngkf-qa.pncint.net/qa1
https://wlm-app.midlandls-qa.pncint.net/qa1-fdic
https://wlm-app.midlandls-qa.pncint.net/qa2fdic `
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}