import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^\\s*(?:\n"
+ " (?<protocol>https?)\n"
+ " \\:[\\/\\\\]{2}\n"
+ " (?<app>[\\w\\-]+)\n"
+ " \\.\n"
+ " (?<client>[\\w]+)\n"
+ " \\-?\n"
+ " (?<environment>[\\w]*)\n"
+ " \\.\n"
+ " (?<audience>[\\w\\.]+)\n"
+ " \\:?\n"
+ " (?<port>\\d*)\n"
+ " [\\\\\\/]\n"
+ " (?<instance>.*?)\n"
+ ")\\s*$\n\n";
final String string = "https://pii.ngkf-qa.commloanservices.com/qa2 \n"
+ "https://pii.ngkf-qa.pncint.net/qa1 \n"
+ "https://wlm-app.midlandls-qa.pncint.net/qa1-fdic \n"
+ "https://wlm-app.midlandls-qa.pncint.net/qa2fdic ";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE | Pattern.COMMENTS | Pattern.CASE_INSENSITIVE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}