$re = '/(\d+)(\,\d+\s)?m[2²]/m';
$str = 'appartement de 4 pièces, 2 chambres, 71,52 m²
appartement de 2 pièces, 1 chambre, 55m²';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);