use strict;
my $str = 'appartement de 4 pièces, 2 chambres, 71,52 m²
appartement de 2 pièces, 1 chambre, 55m²';
my $regex = qr/(\d+)(\,\d+\s)?m[2²]/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}