using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\d+)(\,\d+\s)?m[2²]";
string input = @"appartement de 4 pièces, 2 chambres, 71,52 m²
appartement de 2 pièces, 1 chambre, 55m²";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}