const regex = /(\d+)(\,\d+\s)?m[2²]/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('(\\d+)(\\,\\d+\\s)?m[2²]', 'gm')
const str = `appartement de 4 pièces, 2 chambres, 71,52 m²
appartement de 2 pièces, 1 chambre, 55m²`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}