import Foundation
let pattern = #"(def*\W(\w+)([\w\W]*?))(?=(def)|$)"#
let regex = try! NSRegularExpression(pattern: pattern)
let testString = #"""
def alchol_effect(self, player):
pygame.transform.rotate(player.game.window, 360)
def hope_effect(self, player):
player.game.window.get_rect().move(0, 5)
time.sleep(0.25)
player.game.window.get_rect().move(0, -5)
def mysterious_effect(self, player):
fun = os.path.join("data", "fun")
temmie = get_image(os.path.join(fun, "temmie.png"))
temmie_sound = pygame.mixer.Sound(os.path.join(fun, "temmie.ogg"))
for sprite in player.game.sprites.sprites:
sprite.image = temmie
self.window.blit(temmie)
pygame.transform.rotate(player.game.window, 360*4000)
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)