# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"(def*\W(\w+)([\w\W]*?))(?=(def)|$)"
test_str = ("def alchol_effect(self, player):\n"
" pygame.transform.rotate(player.game.window, 360)\n\n"
"def hope_effect(self, player): \n"
" player.game.window.get_rect().move(0, 5)\n"
" time.sleep(0.25)\n"
" player.game.window.get_rect().move(0, -5)\n\n"
"def mysterious_effect(self, player):\n"
" fun = os.path.join(\"data\", \"fun\") \n"
" temmie = get_image(os.path.join(fun, \"temmie.png\"))\n"
" temmie_sound = pygame.mixer.Sound(os.path.join(fun, \"temmie.ogg\"))\n"
" for sprite in player.game.sprites.sprites:\n"
" sprite.image = temmie\n"
" self.window.blit(temmie)\n"
" pygame.transform.rotate(player.game.window, 360*4000)")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.