re = /(def*\W(\w+)([\w\W]*?))(?=(def)|$)/
str = 'def alchol_effect(self, player):
pygame.transform.rotate(player.game.window, 360)
def hope_effect(self, player):
player.game.window.get_rect().move(0, 5)
time.sleep(0.25)
player.game.window.get_rect().move(0, -5)
def mysterious_effect(self, player):
fun = os.path.join("data", "fun")
temmie = get_image(os.path.join(fun, "temmie.png"))
temmie_sound = pygame.mixer.Sound(os.path.join(fun, "temmie.ogg"))
for sprite in player.game.sprites.sprites:
sprite.image = temmie
self.window.blit(temmie)
pygame.transform.rotate(player.game.window, 360*4000)'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end