use strict;
my $str = 'def alchol_effect(self, player):
pygame.transform.rotate(player.game.window, 360)
def hope_effect(self, player):
player.game.window.get_rect().move(0, 5)
time.sleep(0.25)
player.game.window.get_rect().move(0, -5)
def mysterious_effect(self, player):
fun = os.path.join("data", "fun")
temmie = get_image(os.path.join(fun, "temmie.png"))
temmie_sound = pygame.mixer.Sound(os.path.join(fun, "temmie.ogg"))
for sprite in player.game.sprites.sprites:
sprite.image = temmie
self.window.blit(temmie)
pygame.transform.rotate(player.game.window, 360*4000)';
my $regex = qr/(def*\W(\w+)([\w\W]*?))(?=(def)|$)/p;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}