use strict;
my $str = 'dit is een zin<br/><table><tr><td>Dit moet niet <br/> worden afgebroken<br/></td></tr></table> Nog meer tekst<br/><table>tabel2</table>aaa';
my $regex = qr/((^)|(\<\/table\>))(.*?)((\<table\>)|($))/p;
my $subst = '\\4';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";