const regex = /((^)|(\<\/table\>))(.*?)((\<table\>)|($))/g;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('((^)|(\\<\\\/table\\>))(.*?)((\\<table\\>)|($))', 'g')
const str = `dit is een zin<br/><table><tr><td>Dit moet niet <br/> worden afgebroken<br/></td></tr></table> Nog meer tekst<br/><table>tabel2</table>aaa`;
const subst = `\4`;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);