# If you'd like to omit non-matching lines from the result; add ';d' to the end of the expression.
sed -E 's/((^)|(\<\\/table\>))(.*?)((\<table\>)|($))/\4/g;t' <<< "dit is een zin<br/><table><tr><td>Dit moet niet <br/> worden afgebroken<br/></td></tr></table> Nog meer tekst<br/><table>tabel2</table>aaa"