$re = '/<\/?[b|B][r|R] ?\/?>/m';
$str = '<br />
<br/>
</br>
<br>
<BR>
</BR>
<BR/>
<BR />
br
<br >
<bb/>
<br />';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);