import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "<\\/?[b|B][r|R] ?\\/?>";
final String string = "<br />\n"
+ "<br/>\n"
+ "</br>\n"
+ "<br>\n"
+ "<BR>\n"
+ "</BR>\n"
+ "<BR/>\n"
+ "<BR />\n"
+ "br\n"
+ "<br >\n"
+ "<bb/>\n"
+ "<br />";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}