using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"<\/?[b|B][r|R] ?\/?>";
string input = @"<br />
<br/>
</br>
<br>
<BR>
</BR>
<BR/>
<BR />
br
<br >
<bb/>
<br />";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}