re = /(?:[^@:\->!]*)(?:@)([A-Za-z]+)(?:[^@:\->!]*)(?:\:)([0-9]+)(?:[^@:\->!]*)(?:\!+)(A|D)(?:\!+)(?:[^@:\->!]*)(?:->)([0-9]+)(?:[^@:\->!]*)/m
str = 'pp$##@Coruscant:2000000000!D!->5000'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end