$re = '/(?:[^@:\->!]*)(?:@)([A-Za-z]+)(?:[^@:\->!]*)(?:\:)([0-9]+)(?:[^@:\->!]*)(?:\!+)(A|D)(?:\!+)(?:[^@:\->!]*)(?:->)([0-9]+)(?:[^@:\->!]*)/m';
$str = 'pp$##@Coruscant:2000000000!D!->5000';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);