#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)(?:[^@:\->!]*)(?:@)([A-Za-z]+)(?:[^@:\->!]*)(?:\:)([0-9]+)(?:[^@:\->!]*)(?:\!+)(A|D)(?:\!+)(?:[^@:\->!]*)(?:->)([0-9]+)(?:[^@:\->!]*)"
Local $sString = "pp$##@Coruscant:2000000000!D!->5000"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")