package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)(?:[^@:\->!]*)(?:@)([A-Za-z]+)(?:[^@:\->!]*)(?:\:)([0-9]+)(?:[^@:\->!]*)(?:\!+)(A|D)(?:\!+)(?:[^@:\->!]*)(?:->)([0-9]+)(?:[^@:\->!]*)`)
var str = `pp$##@Coruscant:2000000000!D!->5000`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}