const regex = /[A-Za-z][0-9]{1,7}/;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('[A-Za-z][0-9]{1,7}', '')
const str = `A343534
`;
const subst = ``;
// The substituted value will be contained in the result variable
const result = str.replace(regex, subst);
console.log('Substitution result: ', result);