#include <MsgBoxConstants.au3> ; to declare the Constants of MsgBox
Local $sRegex = "[A-Za-z][0-9]{1,7}"
Local $sString = "A343534" & @CRLF & _
"" & @CRLF & _
""
Local $sSubst = ""
Local $sResult = StringRegExpReplace($sString, $sRegex, $sSubst)
MsgBox($MB_SYSTEMMODAL, "Result", $sResult)