using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"[A-Za-z][0-9]{1,7}";
string substitution = @"";
string input = @"A343534
";
Regex regex = new Regex(pattern);
string result = regex.Replace(input, substitution, 1);
}
}