// include the latest version of the regex crate in your Cargo.toml
extern crate regex;
use regex::Regex;
fn main() {
let regex = Regex::new(r"(?mi)^[a-zéèçà]{2,50}(-| )?([a-zéèçà]{2,50})?$").unwrap();
let string = "Vincent
Ro lan
Thran-suk
Fun yek
";
// result will be an iterator over tuples containing the start and end indices for each match in the string
let result = regex.captures_iter(string);
for mat in result {
println!("{:?}", mat);
}
}