package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?mi)^[a-zéèçà]{2,50}(-| )?([a-zéèçà]{2,50})?$`)
var str = `Vincent
Ro lan
Thran-suk
Fun yek
`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}