$re = '/^[a-zéèçà]{2,50}(-| )?([a-zéèçà]{2,50})?$/mi';
$str = 'Vincent
Ro lan
Thran-suk
Fun yek
';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);