re = /^[a-zéèçà]{2,50}(-| )?([a-zéèçà]{2,50})?$/mi
str = 'Vincent
Ro lan
Thran-suk
Fun yek
'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end