# coding=utf8
# the above tag defines encoding for this document and is for Python 2.x compatibility
import re
regex = r"\DVide[[a-zA-Z]:{\d*}]"
test_str = ("\"<strong>YENİ BİR MACERA</strong><br />\n"
"[Video:{544774}]<br />\n"
"2005 Türkiye Güzeli Hande Subaşı, 2012’de evlendiği Can Tursan’dan Mart’ta anlaşmalı olarak boşanmıştı. Ama daha 2 hafta önce Muğla Akyaka’da eski kocasıyla tatil yapmış, herkesi şaşırtmıştı.<br />\n"
"<br />\n"
"<img style=\"width:100%\" data-url=\"{ServerPath}/images/original/2016/07/21/7835971.jpeg?w=658&h=370\" src=\"//icdncube.posta.com.tr/images/original/2016/07/21/7835971.jpeg?w=658&h=370\" /><br />\n"
"<br />\n"
"<span style=\"color:#FF0000\"><em>Hande Subaşı eski eşi Can Tursan ile 2 hafta önce Bodrum-Akyaka’da tatil yapmıştı.</em></span><br />\n"
"Uçankuş TV’deki ‘İki Kadın Arasında’ programının iddiasına göre; Hande Subaşı, Can Tursan’ı tamamen unuttu, oyuncu Rıza Kocaoğlu ile yeni bir maceraya yelken açtı.<br />\n"
"<strong>BOY FARKI SORUN OLMAMIŞ</strong><br />\n"
"<br />\n"
"<img style=\"width:100%\" data-url=\"{ServerPath}/images/original/2016/07/21/7835969.jpg?w=658&h=370\" src=\"//icdncube.posta.com.tr/images/original/2016/07/21/7835969.jpg?w=658&h=370\" /><br />\n"
"<br />\n"
"Hande Subaşı ile Rıza Kocaoğlu’nun ilişkisi Gümüşlük’te başladı. Geçtiğimiz günlerde birlikte eğlenirken görülen sevgililerin samimi oldukları söylendi. Rıza Kocaoğlu 1 yıllık sevgilisi Eylül Su Sapan’dan 3 ay önce ayrılmıştı.<br />\n"
"<img style=\"width:100%\" data-url=\"{ServerPath}/images/original/2016/07/21/7835971.jpeg?w=658&h=370\" src=\"//icdncube.posta.com.tr/images/original/2016/07/21/7835971.jpeg?w=658&h=370\" /><br />\n"
"[Video:{544774}]<br />\n"
"[Content:{1221834}]<br />\n"
"<strong>Son bir not: Hande Subaşı’nın boyu tam 1.80 santim, Rıza Kocaoğlu ise 1.70.</strong><br />\n"
"<br />\n"
"<img style=\"width:100%\" data-url=\"{ServerPath}/images/original/2016/07/21/7835970.jpeg?w=658&h=370\" src=\"//icdncube.posta.com.tr/images/original/2016/07/21/7835970.jpeg?w=658&h=370\" /><br />\n"
"<br />\n"
"[Content:{1221785}]<br />\n"
"<strong>Rıza Kocaoğlu ile 3 ay önce ayrıldığı Eylül Su Sapan </strong><br />\n"
" \"")
matches = re.finditer(regex, test_str)
for matchNum, match in enumerate(matches, start=1):
print ("Match {matchNum} was found at {start}-{end}: {match}".format(matchNum = matchNum, start = match.start(), end = match.end(), match = match.group()))
for groupNum in range(0, len(match.groups())):
groupNum = groupNum + 1
print ("Group {groupNum} found at {start}-{end}: {group}".format(groupNum = groupNum, start = match.start(groupNum), end = match.end(groupNum), group = match.group(groupNum)))
# Note: for Python 2.7 compatibility, use ur"" to prefix the regex and u"" to prefix the test string and substitution.