#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "\DVide[[a-zA-Z]:{\d*}]"
Local $sString = ""<strong>YENİ BİR MACERA</strong><br />" & @CRLF & _
"[Video:{544774}]<br />" & @CRLF & _
"2005 Türkiye Güzeli Hande Subaşı, 2012’de evlendiği Can Tursan’dan Mart’ta anlaşmalı olarak boşanmıştı. Ama daha 2 hafta önce Muğla Akyaka’da eski kocasıyla tatil yapmış, herkesi şaşırtmıştı.<br />" & @CRLF & _
"<br />" & @CRLF & _
"<img style="width:100%" data-url="{ServerPath}/images/original/2016/07/21/7835971.jpeg?w=658&h=370" src="//icdncube.posta.com.tr/images/original/2016/07/21/7835971.jpeg?w=658&h=370" /><br />" & @CRLF & _
"<br />" & @CRLF & _
"<span style="color:#FF0000"><em>Hande Subaşı eski eşi Can Tursan ile 2 hafta önce Bodrum-Akyaka’da tatil yapmıştı.</em></span><br />" & @CRLF & _
"Uçankuş TV’deki ‘İki Kadın Arasında’ programının iddiasına göre; Hande Subaşı, Can Tursan’ı tamamen unuttu, oyuncu Rıza Kocaoğlu ile yeni bir maceraya yelken açtı.<br />" & @CRLF & _
"<strong>BOY FARKI SORUN OLMAMIŞ</strong><br />" & @CRLF & _
"<br />" & @CRLF & _
"<img style="width:100%" data-url="{ServerPath}/images/original/2016/07/21/7835969.jpg?w=658&h=370" src="//icdncube.posta.com.tr/images/original/2016/07/21/7835969.jpg?w=658&h=370" /><br />" & @CRLF & _
"<br />" & @CRLF & _
"Hande Subaşı ile Rıza Kocaoğlu’nun ilişkisi Gümüşlük’te başladı. Geçtiğimiz günlerde birlikte eğlenirken görülen sevgililerin samimi oldukları söylendi. Rıza Kocaoğlu 1 yıllık sevgilisi Eylül Su Sapan’dan 3 ay önce ayrılmıştı.<br />" & @CRLF & _
"<img style="width:100%" data-url="{ServerPath}/images/original/2016/07/21/7835971.jpeg?w=658&h=370" src="//icdncube.posta.com.tr/images/original/2016/07/21/7835971.jpeg?w=658&h=370" /><br />" & @CRLF & _
"[Video:{544774}]<br />" & @CRLF & _
"[Content:{1221834}]<br />" & @CRLF & _
"<strong>Son bir not: Hande Subaşı’nın boyu tam 1.80 santim, Rıza Kocaoğlu ise 1.70.</strong><br />" & @CRLF & _
"<br />" & @CRLF & _
"<img style="width:100%" data-url="{ServerPath}/images/original/2016/07/21/7835970.jpeg?w=658&h=370" src="//icdncube.posta.com.tr/images/original/2016/07/21/7835970.jpeg?w=658&h=370" /><br />" & @CRLF & _
"<br />" & @CRLF & _
"[Content:{1221785}]<br />" & @CRLF & _
"<strong>Rıza Kocaoğlu ile 3 ay önce ayrıldığı Eylül Su Sapan </strong><br />" & @CRLF & _
" ""
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")