import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "\\DVide[[a-zA-Z]:\\{\\d*\\}]";
final String string = "\"<strong>YENİ BİR MACERA</strong><br />\n"
+ "[Video:{544774}]<br />\n"
+ "2005 Türkiye Güzeli Hande Subaşı, 2012’de evlendiği Can Tursan’dan Mart’ta anlaşmalı olarak boşanmıştı. Ama daha 2 hafta önce Muğla Akyaka’da eski kocasıyla tatil yapmış, herkesi şaşırtmıştı.<br />\n"
+ "<br />\n"
+ "<img style=\"width:100%\" data-url=\"{ServerPath}/images/original/2016/07/21/7835971.jpeg?w=658&h=370\" src=\"//icdncube.posta.com.tr/images/original/2016/07/21/7835971.jpeg?w=658&h=370\" /><br />\n"
+ "<br />\n"
+ "<span style=\"color:#FF0000\"><em>Hande Subaşı eski eşi Can Tursan ile 2 hafta önce Bodrum-Akyaka’da tatil yapmıştı.</em></span><br />\n"
+ "Uçankuş TV’deki ‘İki Kadın Arasında’ programının iddiasına göre; Hande Subaşı, Can Tursan’ı tamamen unuttu, oyuncu Rıza Kocaoğlu ile yeni bir maceraya yelken açtı.<br />\n"
+ "<strong>BOY FARKI SORUN OLMAMIŞ</strong><br />\n"
+ "<br />\n"
+ "<img style=\"width:100%\" data-url=\"{ServerPath}/images/original/2016/07/21/7835969.jpg?w=658&h=370\" src=\"//icdncube.posta.com.tr/images/original/2016/07/21/7835969.jpg?w=658&h=370\" /><br />\n"
+ "<br />\n"
+ "Hande Subaşı ile Rıza Kocaoğlu’nun ilişkisi Gümüşlük’te başladı. Geçtiğimiz günlerde birlikte eğlenirken görülen sevgililerin samimi oldukları söylendi. Rıza Kocaoğlu 1 yıllık sevgilisi Eylül Su Sapan’dan 3 ay önce ayrılmıştı.<br />\n"
+ "<img style=\"width:100%\" data-url=\"{ServerPath}/images/original/2016/07/21/7835971.jpeg?w=658&h=370\" src=\"//icdncube.posta.com.tr/images/original/2016/07/21/7835971.jpeg?w=658&h=370\" /><br />\n"
+ "[Video:{544774}]<br />\n"
+ "[Content:{1221834}]<br />\n"
+ "<strong>Son bir not: Hande Subaşı’nın boyu tam 1.80 santim, Rıza Kocaoğlu ise 1.70.</strong><br />\n"
+ "<br />\n"
+ "<img style=\"width:100%\" data-url=\"{ServerPath}/images/original/2016/07/21/7835970.jpeg?w=658&h=370\" src=\"//icdncube.posta.com.tr/images/original/2016/07/21/7835970.jpeg?w=658&h=370\" /><br />\n"
+ "<br />\n"
+ "[Content:{1221785}]<br />\n"
+ "<strong>Rıza Kocaoğlu ile 3 ay önce ayrıldığı Eylül Su Sapan </strong><br />\n"
+ " \"";
final Pattern pattern = Pattern.compile(regex);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}