re = /^(?:(?:1?[1-9]?\d|[12][0-4]\d|25[0-5])(?:\.(?!$)|$)){4}$/m
str = '123.1.2.3
123.1.1.1.1
266.1.1
00.1.1.1
1234.1.1.1'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end