import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(?:(?:1?[1-9]?\\d|[12][0-4]\\d|25[0-5])(?:\\.(?!$)|$)){4}$";
final String string = "123.1.2.3\n"
+ "123.1.1.1.1\n"
+ "266.1.1\n"
+ "00.1.1.1\n"
+ "1234.1.1.1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}