$re = '/^(?:(?:1?[1-9]?\d|[12][0-4]\d|25[0-5])(?:\.(?!$)|$)){4}$/m';
$str = '123.1.2.3
123.1.1.1.1
266.1.1
00.1.1.1
1234.1.1.1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);