#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)^(?:(?:1?[1-9]?\d|[12][0-4]\d|25[0-5])(?:\.(?!$)|$)){4}$"
Local $sString = "123.1.2.3" & @CRLF & _
"123.1.1.1.1" & @CRLF & _
"266.1.1" & @CRLF & _
"00.1.1.1" & @CRLF & _
"1234.1.1.1"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")