import Foundation
let pattern = #"<([a-z]*)( [a-z]*(=[a-z]*|=".*?")?)*(\/>|>((?R)|[^<>]*)*<\/\1>)|"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
<html></html>
<html><a x>link<br/></a><p>Hi There</p></html>
<html><body class=main tag><img src="foo bar baz"></img></body></html>
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let matches = regex.matches(in: testString, range: stringRange)
var result: [[String]] = []
for match in matches {
var groups: [String] = []
for rangeIndex in 1 ..< match.numberOfRanges {
let nsRange = match.range(at: rangeIndex)
guard !NSEqualRanges(nsRange, NSMakeRange(NSNotFound, 0)) else { continue }
let string = (testString as NSString).substring(with: nsRange)
groups.append(string)
}
if !groups.isEmpty {
result.append(groups)
}
}
print(result)