$re = '/<([a-z]*)( [a-z]*(=[a-z]*|=".*?")?)*(\/>|>((?R)|[^<>]*)*<\/\1>)|/m';
$str = '<html></html>
<html><a x>link<br/></a><p>Hi There</p></html>
<html><body class=main tag><img src="foo bar baz"></img></body></html>';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);