#include <StringConstants.au3> ; to declare the Constants of StringRegExp
#include <Array.au3> ; UDF needed for _ArrayDisplay and _ArrayConcatenate
Local $sRegex = "(?m)<([a-z]*)( [a-z]*(=[a-z]*|=".*?")?)*(\/>|>((?R)|[^<>]*)*<\/\1>)|"
Local $sString = "<html></html>" & @CRLF & _
"<html><a x>link<br/></a><p>Hi There</p></html>" & @CRLF & _
"<html><body class=main tag><img src="foo bar baz"></img></body></html>"
Local $aArray = StringRegExp($sString, $sRegex, $STR_REGEXPARRAYGLOBALFULLMATCH)
Local $aFullArray[0]
For $i = 0 To UBound($aArray) -1
_ArrayConcatenate($aFullArray, $aArray[$i])
Next
$aArray = $aFullArray
; Present the entire match result
_ArrayDisplay($aArray, "Result")