const regex = /<([a-z]*)( [a-z]*(=[a-z]*|=".*?")?)*(\/>|>((?R)|[^<>]*)*<\/\1>)|/gm;
// Alternative syntax using RegExp constructor
// const regex = new RegExp('<([a-z]*)( [a-z]*(=[a-z]*|=".*?")?)*(\\\/>|>((?R)|[^<>]*)*<\\\/\\1>)|', 'gm')
const str = `<html></html>
<html><a x>link<br/></a><p>Hi There</p></html>
<html><body class=main tag><img src="foo bar baz"></img></body></html>`;
// Reset `lastIndex` if this regex is defined globally
// regex.lastIndex = 0;
let m;
while ((m = regex.exec(str)) !== null) {
// This is necessary to avoid infinite loops with zero-width matches
if (m.index === regex.lastIndex) {
regex.lastIndex++;
}
// The result can be accessed through the `m`-variable.
m.forEach((match, groupIndex) => {
console.log(`Found match, group ${groupIndex}: ${match}`);
});
}