$re = '/^(lz|dz|sz)\.[a-z]+\.([a-z]+\.)?([a-z0-9]|-)+(\.v[1-9])?$/m';
$str = 'lz.parsys.bubu.v1
lz.parsys.tbps-partner-akt
lz.parsys.tbps-partner-akt.v1
dz.parsys.partner
dz.parsys.partner911
sz.edwh.partner-created
lz.parsys.cdckafka.tbps-partner
lz.parsys.tbps-partner-akt.1
lz.parsys.tbps-partner-akt.v1';
preg_match_all($re, $str, $matches, PREG_SET_ORDER, 0);
// Print the entire match result
var_dump($matches);