use strict;
my $str = 'lz.parsys.bubu.v1
lz.parsys.tbps-partner-akt
lz.parsys.tbps-partner-akt.v1
dz.parsys.partner
dz.parsys.partner911
sz.edwh.partner-created
lz.parsys.cdckafka.tbps-partner
lz.parsys.tbps-partner-akt.1
lz.parsys.tbps-partner-akt.v1';
my $regex = qr/^(lz|dz|sz)\.[a-z]+\.([a-z]+\.)?([a-z0-9]|-)+(\.v[1-9])?$/mp;
if ( $str =~ /$regex/g ) {
print "Whole match is ${^MATCH} and its start/end positions can be obtained via \$-[0] and \$+[0]\n";
# print "Capture Group 1 is $1 and its start/end positions can be obtained via \$-[1] and \$+[1]\n";
# print "Capture Group 2 is $2 ... and so on\n";
}
# ${^POSTMATCH} and ${^PREMATCH} are also available with the use of '/p'
# Named capture groups can be called via $+{name}