import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "^(lz|dz|sz)\\.[a-z]+\\.([a-z]+\\.)?([a-z0-9]|-)+(\\.v[1-9])?$";
final String string = "lz.parsys.bubu.v1\n"
+ "lz.parsys.tbps-partner-akt\n"
+ "lz.parsys.tbps-partner-akt.v1\n"
+ "dz.parsys.partner\n"
+ "dz.parsys.partner911\n"
+ "sz.edwh.partner-created\n"
+ "lz.parsys.cdckafka.tbps-partner\n"
+ "lz.parsys.tbps-partner-akt.1\n"
+ "lz.parsys.tbps-partner-akt.v1";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}