package main
import (
"regexp"
"fmt"
)
func main() {
var re = regexp.MustCompile(`(?m)^(lz|dz|sz)\.[a-z]+\.([a-z]+\.)?([a-z0-9]|-)+(\.v[1-9])?$`)
var str = `lz.parsys.bubu.v1
lz.parsys.tbps-partner-akt
lz.parsys.tbps-partner-akt.v1
dz.parsys.partner
dz.parsys.partner911
sz.edwh.partner-created
lz.parsys.cdckafka.tbps-partner
lz.parsys.tbps-partner-akt.1
lz.parsys.tbps-partner-akt.v1`
for i, match := range re.FindAllString(str, -1) {
fmt.Println(match, "found at index", i)
}
}