re = /(\w\d=\s\w*)\s(\w*-\w*\s\w*)\s(\w\d+\s\w*\s\w*)/m
str = 'F3= Salir F4-Aceptar Si F11 doble palabra'
# Print the match result
str.scan(re) do |match|
puts match.to_s
end