using System;
using System.Text.RegularExpressions;
public class Example
{
public static void Main()
{
string pattern = @"(\w\d=\s\w*)\s(\w*-\w*\s\w*)\s(\w\d+\s\w*\s\w*)";
string input = @"F3= Salir F4-Aceptar Si F11 doble palabra";
RegexOptions options = RegexOptions.Multiline;
foreach (Match m in Regex.Matches(input, pattern, options))
{
Console.WriteLine("'{0}' found at index {1}.", m.Value, m.Index);
}
}
}