import java.util.regex.Matcher;
import java.util.regex.Pattern;
public class Example {
public static void main(String[] args) {
final String regex = "(\\w\\d=\\s\\w*)\\s(\\w*-\\w*\\s\\w*)\\s(\\w\\d+\\s\\w*\\s\\w*)";
final String string = "F3= Salir F4-Aceptar Si F11 doble palabra";
final Pattern pattern = Pattern.compile(regex, Pattern.MULTILINE);
final Matcher matcher = pattern.matcher(string);
while (matcher.find()) {
System.out.println("Full match: " + matcher.group(0));
for (int i = 1; i <= matcher.groupCount(); i++) {
System.out.println("Group " + i + ": " + matcher.group(i));
}
}
}
}