import Foundation
let pattern = #"^(h[1-6]|p|a|img):\n[\w\-\.\d].*(?=\n{0,}?)"#
let regex = try! NSRegularExpression(pattern: pattern, options: .anchorsMatchLines)
let testString = #"""
h3:
Lorem, ipsum dolor, sit amet consectetur adipisicing elit. Voluptate, perspiciatis.
h4:
Lorem, ipsum dolor, sit amet consectetur adipisicing elit. Voluptate, perspiciatis.
p:
Hello this is a paragraph you can add something to our dsle deglet for more and now how to use this for free
img:
http://www.icon.in/logoe/gksoedfkle/dfkeadka/img.jpg
a:
rahul
p:
are you ready for more thing so what do you think
"""#
let stringRange = NSRange(location: 0, length: testString.utf16.count)
let substitutionString = #""#
let result = regex.stringByReplacingMatches(in: testString, range: stringRange, withTemplate: substitutionString)
print(result)