use strict;
my $str = 'h3:
Lorem, ipsum dolor, sit amet consectetur adipisicing elit. Voluptate, perspiciatis.
h4:
Lorem, ipsum dolor, sit amet consectetur adipisicing elit. Voluptate, perspiciatis.
p:
Hello this is a paragraph you can add something to our dsle deglet for more and now how to use this for free
img:
http://www.icon.in/logoe/gksoedfkle/dfkeadka/img.jpg
a:
rahul
p:
are you ready for more thing so what do you think
';
my $regex = qr/^(h[1-6]|p|a|img):\n[\w\-\.\d].*(?=\n{0,}?)/mp;
my $subst = '';
my $result = $str =~ s/$regex/$subst/rg;
print "The result of the substitution is' $result\n";